Skip to main content

Mounting nfs share on Mac

Mounting nfs share on Mac

Through The Finder

Accessing an NFS share with the Mac OS X Finder is simple. Select Go -> Connect to Server... in the Finder. In the Address box, enter the location of the NFS share as follows nfs:// servername /path/to/share. So if your server's name is taco and the share is /exports/media, you would use the address nfs://taco/exports/media. The Finder will then access the share and mount it on your desktop. An important note here is that the Finder uses an unprivileged port to do this, which may not work with some NFS server configurations.

Through The Mount Command

To use the mount command to mount a share, open the Terminal application. Enter the command sudo /bin/mount_nfs servername: /path/to/share _/private/mnt/point_, replacing the italicized sections with the necessary values. This command will also use an unprivileged port by default, but you can force a privileged port with the -P switch.



Using the automount Daemon

For more permanent mounts, you'll want to configure the automount daemon to handle mounting NFS automatically. On Mac OS X, automount uses NetInfo? to acquire its mounts and parameters. Below are the commands to use to create the necessary data in NetInfo? . As always, replace the values below with those appropriate of your NFS server.

% sudo niutil -create . /mounts
% sudo niutil -create . /mounts/temp
% sudo niutil -createprop . /mounts/temp type 'nfs'
% sudo niutil -createprop . /mounts/temp dir ' _/private/mnt/point_ '
% sudo niutil -createprop . /mounts/temp opts ''
% sudo niutil -createprop . /mounts/temp name ' _servername:/path/to/share_ '


Once you complete these commands, you must signal the automount daemon that a change has occurred. To do this, enter the command

sudo killall -HUP automount.

This configuration also uses an unprivileged port by default. To use a privileged port instead, issue the command

sudo nicl . create /mounts/ servername:\\/ path \\/ to \\/share opts "-P".

Note that the path is escaped using two backslashes preceding each forward slash. Remember to HUP automount after any changes.


Note :

You might face problem in not able to mount the NFS shares exported from a linux box sometimes this is due to mac trying to mount the share through random port. If you want fix this problem then open the /etc/exports file on the linux server where you have exported the nfs share and add " insecure " key to the share config. as below

/mynfs-share *(rw,no_root_squash,sync,insecure,no_subtree_check)

Then try mounting the nfs share again on your mac. This time it should munt successfully.

Comments

Popular posts from this blog

How to find firmware or boot ROM version in Mac OS X

Firmware and boot ROM version of your mac can be found in two ways. Way 1 : 1. From "Apple" menu , choose "About This Mac" menu item. 2. Click " More Info " to open "System Profiler" application. 3. Under Contents -> Select Hardware Tree item. On the right side panel Under hardware overview section, we can see Boot ROM Version and SMC (Firmware) Version. Way 2 : Run the below command in terminal to get boot ROM version and SMC(firmware) version : $ system_profiler SPHardwareDataType | grep -i "Version" | awk -F ':' '{print $1 $2}'

How to extract signing certificates from macOS binary files

Code signing is a macOS security technology that you use to certify that an app was created by you. Once an app is signed, the system can detect any change to the app—whether the change is introduced accidentally or by malicious code. As Apple Developer site says ( click here for more details  on code signing) : code signing allows the operating system to: Ensure that a piece of code has not been altered since it was signed.  The system can detect even the smallest change, whether it was intentional (by a malicious attacker, for example) or accidental (as when a file gets corrupted). When a code signature is intact, the system can be sure the code is as the signer intended. Identify code as coming from a specific source (a developer or signer).  The code signature includes cryptographic information that unambiguously points to a particular author. Determine whether code is trustworthy for a specific purpose.  Among other things, a developer can use a code signature to s

What are the useful nvram settings in macOS ?

The OS X boot arguments are useful for troubleshooting problems with system startup and how the system behaves when running. sudo nvram boot-args="-v" :  This command will set the system to always boot to verbose mode, so we do not need to hold Command + V at system startup. sudo nvram boot-args="-x" :  This will set the system to always boot into Safe Mode. sudo nvram boot-args="-s" :  This command will boot the system into single user mode without needing to hold Command-S at system startup. sudo nvram boot-args="iog=0x0"  :   when you close the display but connect the system to an external monitor and keyboard the system will stay awake. After running this command, when connecting an external monitor, the internal display will be disabled, which can be beneficial in some situations such as those where you are mirroring your desktop but wish to run the external display at a higher resolution than your laptop can run. sudo nvram b