Skip to main content

What is "whatis" and "locate" databases in mac os x? How to Build or Rebuild them ?


On the Mac OS X, Terminal app users can use whatis and locate commands to improve their search experience in the terminal similar to Spotlight. 

whatis :
          
          whatis command gives us the short description about the system commands. To display short description whatis uses its "whatis" database. whatis database is set of database files containing short descriptions of system commands which are commonly used in command line , such as in Terminal app. Mac OS X periodically updates the whatis database on a weekly bases if enabled in periodic.conf file. If whatis database is not built then we can build it with following command
     
      $ sudo /usr/libexec/makewhatis

      or 

      sudo periodic weekly

When we run the whatis command, the output will be as :

      $ whatis system_profiler
      system_profiler(8)       - reports system hardware and software configuration

Locate :

          The locate command provides help in finding or tracking  down every instance of a file, filetype, app, extension, things hidden deep in system folders, or just about anything else that Spotlight can’t manage.To use locate we have to build the locate database. The locate database will be generally gets  created under /var/db/. Run the below specified commands on periodic basis to update your locate database. Locate database is also used by find utility in searching the file/folders.  Locate database can be built by running the following command :

     $  sudo launchctl load -w /System/Library/LaunchDaemons/com/apple.locate.plis

     or

     $ sudo /usr/libexec/locate.updatedb 

     When we run the locate command, the output will be as :

      sh-3.2# locate installer

       /usr/sbin/installer
       /usr/share/man/man8/installer.8


Comments

Popular posts from this blog

How to find firmware or boot ROM version in Mac OS X

Firmware and boot ROM version of your mac can be found in two ways. Way 1 : 1. From "Apple" menu , choose "About This Mac" menu item. 2. Click " More Info " to open "System Profiler" application. 3. Under Contents -> Select Hardware Tree item. On the right side panel Under hardware overview section, we can see Boot ROM Version and SMC (Firmware) Version. Way 2 : Run the below command in terminal to get boot ROM version and SMC(firmware) version : $ system_profiler SPHardwareDataType | grep -i "Version" | awk -F ':' '{print $1 $2}'

How to extract signing certificates from macOS binary files

Code signing is a macOS security technology that you use to certify that an app was created by you. Once an app is signed, the system can detect any change to the app—whether the change is introduced accidentally or by malicious code. As Apple Developer site says ( click here for more details  on code signing) : code signing allows the operating system to: Ensure that a piece of code has not been altered since it was signed.  The system can detect even the smallest change, whether it was intentional (by a malicious attacker, for example) or accidental (as when a file gets corrupted). When a code signature is intact, the system can be sure the code is as the signer intended. Identify code as coming from a specific source (a developer or signer).  The code signature includes cryptographic information that unambiguously points to a particular author. Determine whether code is trustworthy for a specific purpose.  Among other things, a developer can use a code signature to s

What are the useful nvram settings in macOS ?

The OS X boot arguments are useful for troubleshooting problems with system startup and how the system behaves when running. sudo nvram boot-args="-v" :  This command will set the system to always boot to verbose mode, so we do not need to hold Command + V at system startup. sudo nvram boot-args="-x" :  This will set the system to always boot into Safe Mode. sudo nvram boot-args="-s" :  This command will boot the system into single user mode without needing to hold Command-S at system startup. sudo nvram boot-args="iog=0x0"  :   when you close the display but connect the system to an external monitor and keyboard the system will stay awake. After running this command, when connecting an external monitor, the internal display will be disabled, which can be beneficial in some situations such as those where you are mirroring your desktop but wish to run the external display at a higher resolution than your laptop can run. sudo nvram b